ABS System Failure, VDC System Failure, EBD System Failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 11-09-10 Thread Starter
Status: -
Join Date: Sep 2010
Location: Australia
County: New South Wales
Posts: 4
ABS System Failure, VDC System Failure, EBD System Failure

I bought my 147 2.0 Litre Manual new in November 2005 and haven't had any real problems with it until now. I should add that it's often garaged for several months without being driven.

In fact, I left it in my garage (with the battery disconnected) last April and returned home two days ago. Thursday I reconnected the battery and all seemed fine - I only drove the car a couple of kms but nothing was amiss. Yesterday, however, I had driven about 5 kms when I noticed two 'warning' messages appear. The first said ABS System Failure, the second said VDC System Failure. There didn't appear to be anything wrong with the car and I couldn't pull over so I continued to drive until I got to the car park at my destination and I realised that I couldn't put the driver's window down to take the ticket from the machine at the car park. I opened the door to take the ticket and then parked the car. After I switched off the engine, I tried to turn on the ignition once more but the battery was completely flat

I called the NRMA but the mechanic who attended told me the problem appeared to be that the alternator wasn't charging - he arranged for the car to be towed to a local garage (the one where I had the car serviced 12 months ago). I had a brief call to the garage (it was closing time) and was told that alternators can fail without any prior notice.

Was just wondering if anyone might be able to suggest whether this is the most likely cause of the error messages - I had a new battery installed 12 months ago and it has only been used for 6 months and has been disconnected for the past 6 months.
Scadger is offline  
Sponsored Links
(Post Link) post #2 of 4 Old 11-09-10 Thread Starter
Status: -
Join Date: Sep 2010
Location: Australia
County: New South Wales
Posts: 4
Just to update ....

Have spoken with my garage who tell me that their auto electrician says I need to replace the alternator! Is this normal? I thought that alternators were supposed to last for 100,000+ kms (my car has done 25000 kms in 5 years).

Does anyone know how much a new alternator for a 147 should cost?
Scadger is offline  
Status: -
Join Date: Jan 2012
Location: Australia
County: Victoria
Posts: 1

Member car:

Alfa 156

Did you ever get this fixed?

Scadger... I have same problem with my 156.... Did you ever sort out your problem? Thanks
RGM1971 is offline  
Status: -
Join Date: Jun 2012
Location: Turkey
County: Bursa
Posts: 4
Help ABS, VDC, EBD system failure

Hi guys,

I drive a 2006 156 TS distinctive. Last year in the summer I had this ABS, VDC, EBD error and go to dealer warnings. I went to service and they asked me to leave the car 10 - 15 days with no specific explenation about the problem. They told me according to diagnosis it could cost much.

I then found out these forums and tried a couple of tricks. First replaced 60 amp fuse in the fuse box over the battery and it worked for nearly 2 months. I was so happy until I see that failures occured again. Then I got my car to a mechanic and they advised to change the battery. Hooops, it worked again and didn't have the problem almost 7 - 8 months.

Now unfortunately I have the same problem, ABS, VDC and EBD errors occures. My battery is not dead (green point on the battery ) and I see no physical problem with the fuse.

When this errors occur, the air conditioner seems to blow air much faster for a couple of seconds.

Can anybody help me and tell me what to do more?
BarisKutahya is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

abs , ebd , failure , system , vdc

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome