147 JTDm 16v cam top pully noise - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-09-10 Thread Starter
Status: -
Join Date: Sep 2010
Location: United Kingdom
County: Newport
Posts: 1

Member car:

147 JTDm 16v

147 JTDm 16v cam top pully noise

Hey all,

After being a browser of alfa owner for a good 8 months i finally decided to join.

Diving straight in to my issue I have an 05 (32k) 147 JTDm 16v and am getting a strange squeak comming from the top cam pully area and was wondering if anyone had any ideas as to what it could be, it does speed up with RPM increase to an extent that you cant hear it any more but on idle its back again. i was wondering if it could maybe be a tensioner? The cam belt was changed in june along with the waterpump, i am assuming it would have been a cambelt kit that should have come with tensioners though right?

Any thoughts appreciated

Rebus is offline  
Sponsored Links
Status: - Update
Posts: n/a
Had a squeaking coming from the belt area (but never really dug deeper than that), very easy to hear at idle as well, but only after longish drives, not from cold - it turned out to be one of the idlers on the accessory belt.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , 16v , cam , jtdm , noise , pully , top

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome