Selespeed pump - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 05-09-10 Thread Starter
Status: -
Join Date: Jul 2010
Location: United Kingdom
County: South Yorkshire
Posts: 3

Member car:

147 lusso

Selespeed pump

Ayup All
I've got a 147 2.0L selespeed I had to call out the AA because dropped into neutral and would'nt select any gear. I knew it was the selespeed pump because there was silence when opening the door or turning on the ignition I just expected being towed home.The AA guy knew his stuff justed tapped the selespeed pump and bingo back up and running looks like worn brushes. My question is can the brushes be replaced? How big a job is it to change the pump? and has anyone have a pump for sale?
Cheers Kev
gixerkev is offline  
Sponsored Links
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
Check the sele relay (black square one on its own under the air intake somewhere). It might just be that it has dirty contacts.

Some have fitted audi windscreen wiper motor brushes, but I don't think they lasted long.

New pumps are £150 ish, I think... Check ebay though, you might find a decent used one if it comes to that.

I did have one, but I sold it to a guy in Texas!
iainfm is offline  
Status: Alfa infected
AO Gold Member
purple145's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: West Midlands
Posts: 7,026
brushes can be replaced, using brushes from an Audi wiper motor apparently, however bit of a bodge and may need a few goes to get right. Otherwise it is new pump time, pump approx £280, not hard, front bumper and inner wheel arch off and then you can get to it, only watch out is to de-pressurize the system before undoing the high pressure pipes, either by not opening the drivers door after leaving overnight (use passenger to release bonnet) or pull the relay out and change gear a few times until it changes no more. Several hints on here if you do a search.

Good work by the AA man, they usually run a mile from a silly,

or is it, if all else fails hit the thing with a hammer?

purple145 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

pump , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome