Cooling on 3.2 GT - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #26 of 26 Old 09-09-10 Thread Starter
Status: Almost Bankrupt
AO Member
Join Date: Nov 2009
Location: United Kingdom
County: Northumberland
Posts: 87
Images: 2

Member car:

Alfa GT Coupe V6

Conflicting theories I suppose I read too much into things. Anyway returned to Quicksale today and Simon all round good guy takes me and my car for a "Spirited drive" nice to be a passenger for a change, we drove until the Temp gauge rose it hit an indicated 95 then it went onto 100 but as soon as we pulled into the layby temps dropped to 90 Fans running rear of the engine bay was relatively cool and coolant was whizzing round as it should. It seems that my nice new clocks are super sensetive and are receiving the readings in real time from the ECU a bit like my old RD500LC used to do. So I have replaced the Temp sender as a precaution and will just get used to the Needle moving up and down sorry for annoying everone but having only owned cars where the Temp gauge never ever moved to this one that seems to work in real time is strange.
Johnny43-UK is offline  
Sponsored Links

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome