Alfa Romeo 156 2.0 TS Performance Issue - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 02-09-10 Thread Starter
Status: -
Join Date: Sep 2010
Location: United Kingdom
County: Cambridgeshire
Posts: 1
Alfa Romeo 156 2.0 TS Performance Issue

I have recently purchased a Sport Pack 3 156 2.0 TS and when I am driving the car if I put my foot down once the engine hits 3000 RPM the power tails off. It seems like it is only firing on 3 cylinders yet when idling or below 3000 RPM the engine is fine. This is a little frustrating as I am now able to enjoy the smooth delivery of power. Any Ideas?
freestyleFunker is offline  
Sponsored Links
Status: -
AO Member
Join Date: Feb 2010
Location: United Kingdom
County: Essex
Posts: 301

Member car:


MAF or throttle position sensor as a guess - you will need to put it on diags
alfa amore is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , issue , performance , romeo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome