Strange Vibration/noise - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-08-10 Thread Starter
Status: -
AO Member
Join Date: Jan 2008
Posts: 15

Member car:

Fiat Coupe 20VT

Strange Vibration/noise

Hi I've got a 51 plate 1.8TS
A very strange noise has appeared that sounds like maybe something rubbing or vibating from the front of the car. It seems to happen more when the car is loaded up with people and mainly when turning left. I've had a look under the car but I can't see any evidence of rubbing that is obvious, the wheel bearings seem ok. It doesn't allways seem to happen and the intensity seems to vary, it can also be felt and I am quite concernd about driving the car. I thought it may have been the upperwish bones allowing movement as they were quite worn, now replaced, it has also had new front pads before this noies appeared. I would be very gratefull for any clues/advice
rogerdodge is offline  
Sponsored Links
Status: missing Inverurie
AO Gold Member
Pascs's Avatar
Join Date: Apr 2002
Location: Qatar
County: Aberdeenshire
Posts: 8,063
Images: 16

Member car:

Zender 156 V6

Pads or caliper / spring not fitted correctly or spring missing?
Pascs is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

strange , vibration or noise

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome