156 Selespeed engine - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 21-08-10 Thread Starter
Status: -
Join Date: Aug 2010
Location: United Kingdom
County: Kent
Posts: 1

Member car:

156 Selespeed

156 Selespeed engine

Hello everyone
I have a 2000 alfa romeo 156 2.0 Selespeed with knocking engine sound. Spend some time on it and found one of the big end gone. So went to the main dealer's and bought a pair of shell bearings which cost me 20 replaced them and after that still wasnt good enough as it on low RPM sounds just perfect and on high rpm still knocking but not this much as before. Also it losses power and smokes a lot. Any Ideas about that?
Im looking for the new engine or just a complete block for not a high price If anyone got something to offer please let me know 07548885799.
Or any advise what could be wrong on it as i Guess the crankshaft could be damaged as well, cause the shell bearings were left thin as paper and the top one was half way down on the bottom one.
kissas is offline  
Sponsored Links
Status: Freezing!
AO Silver Member
Rockhopper's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Nottinghamshire
Posts: 4,861
You should have changed all the shells really not just one pair, plus you should measure the journal to see if its still within the limits for overall size and also for roundness.
No real idea about the smoking though although if its a petrol car it tends to point to bore/piston ring wear.
Rockhopper is offline  
Status: -
Club Member
Membro Medio
ALFAPAT's Avatar
Club Member Number: 237
Join Date: Nov 2001
Location: United Kingdom
County: Moray
Posts: 1,862
Images: 6
That crank should have been out and reground.From what you say if the shells have spun then the journals are worn so fitting standard shells to a scored crank will 100% not work, sounds like a bit more trouble than that though!
ALFAPAT is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , engine , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome