147 Bad Luck and Dilemma - comments welcome - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 20-08-10 Thread Starter
Status: -
alfastives's Avatar
Join Date: Feb 2010
Location: United Kingdom
County: Cornwall
Posts: 4
147 Bad Luck and Dilemma - comments welcome

The offending car: 147 51 plate 2.0 ts Lusso Selespeed with 72k on the clock, interior is v. good condition with tan leather and the bodywork is okay.

The car last had its cam belt changed on 44k so i thought i have plenty of miles left on the car before it needed doing again (ie 80k miles). The MOT is due in October so like a good boy i booked it into the local main dealer to have the mega service (timing belt, cam belt water pump etc) i was quoted 700 odd pounds which was fine as it needed doing. Anyway, on the way to garage - more like 500 metres away! the car dies - engine managment light, car stops and i get the Selespeed failure message.

With my girlfriend in the left in the car i walk to the garage, they come over with the PC and cable to tell me the dreaded news - timing belt has gone. Cut a long story short - its looks as though it needs a new cyclinder head and its bent about 8 of the valves he has not given me an actual quote but its looks as though its gonna 2K at the very least. For the record Bradleys in Cornwall have really been great and very understanding at my plight!

My questions are this

Is this a far price?
Should i cut my losses and not throw good money after bad?
Whats it worth scr*wed?
They offered me a grand agaisnt a new car (ie MITO) which i am seriously considering (plus the money i had budgeted for the service then on the drip) but i do bloody love my 147 and was planning to keep it, at least, for another couple of years.

Your comments would be very grateful......
alfastives is offline  
Sponsored Links
Status: - Update
Posts: n/a
Oh dear, that's just about the worst case of bad luck I've ever heard! I hope it isn't bad Karma - if it is, what on earth did you do to deserve it?!!

Assuming it's the former, 2000 sounds a bit steep to fix it, I'm sure you could get a recon 2L for a lot less than that, fitted. Have a search around.

But the car is probably only worth around 1600 in market value terms anyway? I guess it boils down to how much the car is worth to you, and whether it'll cost more than that to fix it.

In itself, 1000 against the cost of a new MiTo is probably quite fair. But how much would you have got off a new MiTo by negotiation anyway?
Status: -
AO Member
Join Date: Jul 2010
Location: United Kingdom
County: Denbighshire
Posts: 16

Member car:

147 lusso

Sure Ive seen full engines for less than 1k? dont know milege or condition though? get one of them and fitted must be less than 1.5k?

I just bought the wife 02 147 luso 2 ltr 60k full service history, leather, satnav, cup alloys,basically fully loaded for a tad over 2k. Might be worth selling yours for few hundred and put the 2k for new engine plus cash from sales towards another.

Mind you matey I know nothing about machanics etc!!!!! Im just saying what I would do!
cgizzi is offline  
Status: -
Join Date: Nov 2009
Location: United Kingdom
County: South Ayrshire
Posts: 8

Member car:

alfa 147

i'm not as bad as you mate but kinda in the same boat, need a new car for work but love my 147. tax, mot and service all due over the next month i have to wonder would i just be throwing money away. Arnold shark have an ex demo bravo 165 diesel sport 59 plate for roughly 10k and it's looking very tempting depending on the trade in value they give me.
saintj is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , bad , comments , dilemma , luck

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome