engine management system failure!!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 12-08-10 Thread Starter
Status: -
AO Member
Join Date: Sep 2007
Location: IRELAND
Posts: 96
engine management system failure!!!!

I know this is a common one one alfa's but my wee 147 1.6 ts put's on the light around 5500rpm i have to switch it on and off 6 time's before the light goes out again. The problem started about 2000 mile's ago when she went for the crank sensor I changed it but the light still came on but it increasingly let me rev further as time went on until it reached 5000rpm and tbh I never really revved it passed so I kinda forgot all about so today I did the ECU reset procedure now I get as far as 5500rpm and it come's on. Car goes really well so am kinda stumped.
tommi is offline  
Sponsored Links
Status: -
AO Member
Join Date: Aug 2011
Location: Austria
County: Tirol
Posts: 111
A bit late but I took my GT 1.9jtd a couple days ago to Alfa (again...) to get a problem with the turbo fixed (basically needed a lot of cleaning but under warranty so I wasn't fussed) but they said they had broken something called an "Emissions control valve" (don't quote the translation, that is what I was told in German and I really do not know much German), anyway head mechanic said the car should run and feel exactly the same except for the annoying engine warning light "engine managaement system failure". It will get replaced by Alfa after the new year, in the mean time I have a 3000km round europe drive starting tomorrow and ending on the 8th of Jan, hope the mechanic is correct and nothing more serious is caused by this....

ANyone got any idea what the "emmisions control valve" is????
06gt is offline  
Status: DEFCON5
AO Gold Member
1of1's Avatar
Join Date: Oct 2010
Location: Sao Tome and Principe
County: Principe
Posts: 11,605
Images: 7
EGR valve?
1of1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , failure , management , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome