Fuel consumption Alfa 2.4 JTD. Fake data from board? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 12-08-10 Thread Starter
Status: -
AO Member
oem's Avatar
Join Date: Feb 2009
Location: Bulgaria
County: Veliko Tarnovo
Posts: 17
Fuel consumption Alfa 2.4 JTD. Fake data from board?

Hello. I have a problem with the Alfa 2003 150 2.4 JTD 10V horse. The car runs without problems. While running the trip computer showing fuel consumption from 5.6 to 8.5 l / km, but when i back the gas pedal momentum and fuel consumption jumps to 50/100. Watch real-time injection stops. 0.00 mg / i. However, the owner says that his real forests with over 3 liters. This is about 11/100. The car has a chip tuning!

What could be linked to this indication of the board?

Diagnostics found slight malfunction MAF sensor and then cleaned it from dust with a spray flow meters and began to report well. Pressure rail holds up well as idling has 300 bars.

Initially there was an error in the recorded ERG valve P0404. As i think it was INVALID SIGNAL. Man said he is clean ERG after a mistake after deleting does not appear anymore.

Here is the log of diagnosis: log.rar - 4shared.com - online file sharing and storage - download

Board should in principle take the info from the quantity of fuel injected and possibly speed of the car. There is a problem and I can not think of what can be?

Anybody got an idea?

Alfa Romeo 156
oem is offline  
Sponsored Links
Status: -
AO Member
Jeronimo's Avatar
Join Date: Feb 2006
Location: Gretton, Northants
Posts: 111
Images: 9
Hi there, I have almost the same vehicle (remapped 150HP 10v 2002). I have a little difficulty to interpret your message but I am sure your English is better than any attempt by me at your native language

The computer will give 3 readouts for fuel consumption (mine is in miles per gallon (mpg) not l/100km).

1) it will give the average consumption since the ECU was last reset (battery disconnected)
2) it will give your instant mpg, as you are driving.
3) on more pushes of the button it will give your average mpg for the journey (journey B) you are making at that time.

If you set the computer readout on 2) you will see the mpg go up and down depending on what you are doing with your right foot. If you travel at 100km/h and lift your right foot off for a long time the readout will go to a maximum and on my car this is about 144.3 (I think) mpg. It never goes above this even though there is no injection of fuel taking place.

Floor the pedal with the right foot and the readout will go down to less than 30mpg. (I will leave you to convert these amounts to l/100km )

My overall average mpg is more than 52 - but I am gentle with my right foot ....... mostly

Hope this helps, Jerry

2002 156 2.4JTD Sportwagon
Remap + Koni FSD's = Loverly
Jeronimo is offline  
Status: Enjoying a nice mug of tea
AO Silver Member
Join Date: Oct 2008
Location: United Kingdom
County: Bedfordshire
Posts: 1,752
If you have had the chip tuned then the on board consumption will read wrong (It is not that accurate and tends to give you a higher reading than is the truth).

The only way to get a true reading id to fill the tak to the brim, drive, and refill to the same level then calculate from the distance traveled and fuel used.
CJO is offline  
Status: - Update
Posts: n/a
Mine (2.4 20v) gives incorrect data even without a chip tuning. It says averages of 6 - 6.5 l/100 km, I was never able to achieve anything below 7.3 l / 100 km (and mind that was over a 700 km trip, with cruise control set at 125 km/h).
Status: -
AO Member
Join Date: Feb 2010
Location: United Kingdom
County: Cheshire
Posts: 30

Member car:

'10 Fiat 500

Everything i have ever read about JTD fuel consumption says don't trust the readout. If I want to know I do the sums myself (which always gives the depressing reality that my car is doing alot less MPG than it should be!!)
156alex is offline  
(Post Link) post #6 of 6 Old 13-08-10 Thread Starter
Status: -
AO Member
oem's Avatar
Join Date: Feb 2009
Location: Bulgaria
County: Veliko Tarnovo
Posts: 17
It's this clear. This computer showed that is kilometers per liter. When i switched readings to liters per 100 km everything came into place.

The real high fuel consumption proved to be a problem in the thermostat. Today, i measured the actual temperature of the engine and proved that it does not exceed 73 degrees Celsius. The other problem was blocked relay for the first level of the fans. First speed was constantly active. Even if only on MAR and engine is cold. After cleaning the relay the problem no longer exists.

Tomorrow i will replacing the thermostat and will test for fuel consumption.
oem is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alfa , board , consumption , data , fake , fuel , jtd

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome