purge valve - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 28-07-10 Thread Starter
Status: -
AO Member
Join Date: Dec 2007
Location: bridgwater,somerset
Posts: 41
purge valve

hi to all
i have got a fault with my car 156 ts 1.8 1998, the prob is ticks over fine , get past 4000 rpm ish fine , the prob is the middle bit stutters and stall with no power

this is what i have done changed airflow meter, changed lamba sensor, checked injectors seals and changed, checked inlet pipes and changed 1 that had split, checked exhaust took all apart re-sealed, now ticks over the best ever but still has problem?

this is what i believe it might be, purge valve, got voltage ok, but no hissing when removed filler cap from tank and no smell of petrol if i remove blue pipe when travling along, also i believe if should be a reading of 26 on the meter.

am i correct in believing this colud be the problem? if i am on the right road where can i get the bit? direct from alfa? or can they be bought aftermarket?

i have tried alfa and the bloke at the parts desk could not find the seperater bit again is this correct, can someone check there eper for me as my copy does not want to work

cheers for any help
mrtalfaman is offline  
Sponsored Links
(Post Link) post #2 of 2 Old 06-08-10 Thread Starter
Status: -
AO Member
Join Date: Dec 2007
Location: bridgwater,somerset
Posts: 41
have some more info on the problem the voltage to the purge valve is on the white wire 14 volts and the blue wire between 0 and 6 volts, is this correct?
also purge valve is working properly getting his from tank
still have the problem but working on it but if you have any idears let me know please
mrtalfaman is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

purge , valve

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome