156 1.8 fuel pump - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 28-07-10 Thread Starter
Status: -
Join Date: Jul 2010
Location: United Kingdom
County: Durham
Posts: 1

Member car:


Hmmm 156 1.8 fuel pump

Bare with me i`m not too good with `technical terms' i recently purchased a 2000 w reg 156 1.8ltr from a back street garage.
i paid £850 for the car and it drove lovely without checking my docs properly i left the garage and found out the car had less than 6 wks test on it although advertised a full mot!!! i have since contacted the garage i aparently he is no longer and trading and some `new' peoplwe have taken over although same number different name ???

anyways i took the car for its mot yesterday in which it failed on the following items.

1. front light was too far over - not getting a proper connection
2. Some one had converted the front windscreen `sprayers ' from double to single and theree was not enough water passing through to cleamn windows.
3. immunisitions were high but nothing to do with exhaust, tester seems it something to do with revs and will need a diagnostic check.

i drove the car home from the garage it was fine no probs but later when i went out i could not start the car green flag came out put some more fuel in but was not registering thinks it is most likely to be fuel pump i am just wondering is this what could be effecting the revs and also are all these easy fixes i dont have a lot of money to spend but the car is too good to scrap!!
sorry i know this message is long winded and any advice would be greatly appreciated.

peck is offline  
Sponsored Links
Status: Freezing!
AO Silver Member
Rockhopper's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Nottinghamshire
Posts: 4,861
1. Its easy to get the headlight bulbs in upside down -maybe thats whats happened here. Easy to check, just take the bulb out and make sure the filament is hanging down rather that up if you get what i mean!

2. Why would someone do this? Get some from a breakers and put the twin ones back on. However depending on the type of wipers fitted it can be difficult to get the spray to hit the screen and not the wiper.

3. Think you mean emissions are high. Yep,get i diag check done,preferably by an Alfa Specialist.

How much fuel did green flag put in? In my experience people who do not understand Alfas think that any non starting problem is either the cam belt or the fuel pump. Again, you'd be best off getting the error codes read.

If you have a lap top and a few quid you can buy the software and lead and read the codes yourself, might be easier than trying to get a non runner to a garage.
Rockhopper is offline  
Status: -
AO Member
Join Date: Dec 2007
Location: bridgwater,somerset
Posts: 41
did you car start? if it did but now and again cuts out wont start, sounds like crank sensor, i have changed one of these (check my threads out), could be the chip in the key if i stall mine wont start unless take key out and put it back in.
had a few probs with mine so might be able to help out, cheers
mrtalfaman is offline  
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,069
I wouldn't bother with second-hand washer jets...they are only a few quid - literally £3 - £4 - from Alfa, and the proper ones do give a good spray!

As for the fuel pump - very rare for them to fail - check the cut-off switch under the front passenger seat......and listen carefully when you turn the ignition on - you should hear the pump run briefly. It can be necessary to put a couple of gallons in if they've run dry, particularly if the car is on a slope......
rgwm is offline  
Status: drifter
AO Silver Member
Join Date: Dec 2009
Location: United Kingdom
County: West Sussex
Posts: 1,067
I ran a 147 dry recently and 1 gallon was not enough fuel to start the car.
seymour beaver is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , fuel , pump

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome