Alfa 147jtd injector - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 23-07-10 Thread Starter
Status: -
Join Date: Feb 2010
Location: United Kingdom
County: Oxfordshire
Posts: 2

Member car:

Alfa 147jtd mjet

Alfa 147jtd injector

Couple of weeks ago my alfa 147jtd 16v failed to start thought i was stranded at work,. left the car for ten minutes tried again and by some miracle it started.Unfortunately the "monitor control system failure came on highlighting something is wrong.After about 12 turns of the ignition the engine warning light disppeared .However , i had it plugged it to a diagnostic machine and straight away it came up with the secondary injector isnt working or faulty. According to my brother{whose a mechanic }the car would not start with one faulty injector but whats confusing is the car is running sweet. Is it possible that the engine can run on three injectors or is something else faulty that is linked with the injector?Does anyone know?
Many thanks

Last edited by alfa spirit; 23-07-10 at 09:57. Reason: missing word
alfa spirit is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147jtd , alfa , injector

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome