147 clicked when reversing now oil everywhere - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 19-07-10 Thread Starter
Status: -
Join Date: Jul 2010
Location: New Zealand
County: Manawatu-Wanganui
Posts: 1

Member car:


Hmmm 147 clicked when reversing now oil everywhere

Hi guys, I was coming home from my grandparents tonight in my 2005 147 selespeed, 2.0 petrol, when i reversed i herd a loud crunch but i figured i had just run a can or pine cone or something over i put it in 1st and proceeded to drive, it made a few clicking sounds like a loud cv joint clicking but in a few seconds that disappeared and i continued on my way. Soon I thought about it more and pulled over to check it out, the car was driving fine. It was dark so i just put my hand behind the left front wheel to see if i could see, feel anything wrong and sure enough oil was everywhere. I had to get home as i had my wife and baby in the car in the middle of nowhere so decided to risk the 45 min drive home. All went well except when I got home and tried to reverse into the shed it feels as though it doesnt want to go backwards and i dont want to break anything else. Any ideas as to what has happened?
deans is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , clicked , oil , reversing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome