Alfa 156 2.4 JTD, 2000., weird turbine problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 14-07-10 Thread Starter
Status: -
astrbac's Avatar
Join Date: Jul 2010
Location: Croatia
County: City of Zagreb
Posts: 5
Alfa 156 2.4 JTD, 2000., weird turbine problem

Hello everybody!

My first post here so please be gentle :-). I have recently bought a used Alfa 156 JTD with some 130.000miles on the clock, hit here and there but mostly in good shape. I have fixed it for the most part, except for one strange thing.

When I turn it on in the morning, drive it for about 20, 30 miles everything is fine. Mind you, I always drive it at up to 2000-2500 rpm. Then, all of a sudden, something "clicks", like a clamp, hose or something falling out of its place and turbo charger starts whining like an ambulance siren. Not that loud but really loud....

The pitch increases as I press the gas pedal... I can't really describe it but it's this metallic siren sound. I went to see turbo specialist who took the charger off of the car, repaired it, balanced the axle (?), changed the bearings and said that it should be fine for another year or two and should then be replaced.

I haven't tried really forcing it when that happend so I can't say if the car would go into limp mode or not. Any ideas? Wastegate (EGR valve), turbo burned, ...?
Thank you!
astrbac is offline  
Sponsored Links
Status: Banned for not following the site rules
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
Images: 6
If they'd gone to all that work then wy nnot just have replaced it then and it would have cost less, but it could be the aircon clicking in and something trapped inside the clutch ring.
Smaky is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 2000 , alfa , jtd , problem , turbine , weird

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome