147 engine sounds quite loud - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 04-07-10 Thread Starter
Status: -
porkchopexpress's Avatar
Join Date: Jun 2010
Location: United Kingdom
County: Berkshire
Posts: 4
147 engine sounds quite loud

Hi guys

I now have my second post asking for advice for my new car and I've only had it a month.

I have a 2.0L 2002 147 with 86000 miles on the clock. The engine sounds quite loud when standing outside. I can't quite describe the sound as I can't hear ticking or knocking it's just quite loud. Itís not so noticeable inside the car.

It had quite a bit of work done in Jan this year (this was the reason why I chose the car) which included a new cam belt and variator. People have mentioned getting the water pump changed at the same time as the cam belt in other threads. This wasn't on the receipt, should I look at getting this changed soon?

I had a problem a few weeks ago where one of the ignition coils melted. Quite a few other parts were damaged by this so it was quite a pricy repair. I just thought I'd see if anyone had any ideas on whether the loud engine is a problem or if I'm being a tad paranoid following an unlucky problem after buying the car.

Thanks for your help
porkchopexpress is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jun 2010
Location: Australia
County: Australian Capital Territory
Posts: 18

Member car:

147 2.0 Manual

Does it sound like a diesel?
Does the sound smooth out after 1750 RPM?

Could well be the Variator
tacoflavour is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , engine , loud , sounds

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome