156 ts selespeed gear box/ clutch (i think) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 28-06-10 Thread Starter
Status: -
Join Date: Jun 2010
Location: United Kingdom
County: Cumbria
Posts: 4

Member car:

mk3 mondeo st

156 ts selespeed gear box/ clutch (i think)

hello i need some help.
i got my first alfa on sat, its also my first tiptronic gear box. its been fine until today, i got into it went to set off and the car was just reving. i reselected 1st it took till approx 4000 rpm before the car would select first and set off. i was in rush hour and it has continued to do this in first and has been a little funny in second. has anyone any idea what the problem might be pls help.. thanks paul
pockets1 is offline  
Sponsored Links
Status: Banned for not following the site rules
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
Images: 6
clutch rod length and Calibration time.
Smaky is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , box or , clutch , gear , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome