Hi i am new to alfa ownership - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 27-06-10 Thread Starter
Status: -
AO Member
1.8 156's Avatar
Join Date: Jun 2010
Location: United Kingdom
County: West Yorkshire
Posts: 16
Images: 2

Member car:

alfa romeo 156

Hi i am new to alfa ownership

Hi my name is Craig and i have just bought my first Alfa its a w reg 156 1.8 t spark with 38000 miles on the clock its in concourse condition i love it and do not know why i have not ever bought one before!
As seems too be the case i already have a problem and am wondering if someone can point me in the right direction? last night my windscreen wipers just stopped working so i instantly checked the fuse and found it too be blown, i replaced it and tried the wipers and it blew again after about 2 minutes, any ideas what this could be??

Any advice is much appreciated


1.8 156 is offline  
Sponsored Links
Status: - Update
Posts: n/a
Hey Craig,
cant help with your blown fuse other than to encourage you to contact someone called Smaky on this forum. He is wise and will undoubtedly know what to do.
Welcome to Alfaowner and indeed Alfa ownership

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alfa , ownership

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome