Whince whenever I push the clutch pedal down - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 19-06-10 Thread Starter
Status: -
AO Member
DavidB's Avatar
Join Date: Jun 2006
Location: Whitehill Hampshire
Posts: 86

Member car:


Whince whenever I push the clutch pedal down

My GT 1.9 JTDm has a problem with the clutch pedal action. It has been similar from new but now it has done 55K miles it seems to be getting worse, or maybe I am getting sensitised to it. When cold in the morning the clutch pedal operates silky smooth. After a few hours motoring it feels horrible as I depress the clutch to change gear. There is a creaky notchy feeling to it. I have coated everything I can see or feel with: silicone spray, WD 40, spray-on white grease, ordinary grease, engine oil, all to no avail. If it pump the clutch pedal repeatedly and fast it goes away for a few strokes but soon comes back. If it is raining the problem disappears. The clutch itself takes up about halfway up and there is no sign of judder or slip. Anyone got an answer?
DavidB is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jun 2008
Location: Norway
County: Nordland
Posts: 25
No answer, but I have similar problem on my 166.
I have got new clutch, release bearing and gear wires.
The gear selector bushes are also new.
It is worse when it,s hot in the weather.
My next step is to change the clutch slave cylinder.
When this happens, the gearchange become notchy.

rasa28 is offline  
Status: Banned for not following the site rules
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
Images: 6
Cluth master cylinder internal spring snappage.
Smaky is offline  
Status: -
AO Silver Member
Join Date: Dec 2009
Location: United Kingdom
County: -
Posts: 1,171

Member car:

147 JTDM 16V

There are a load of threads on here regarding this problem which seems to affect a lot of people. My cars the same ... I've just decided to put up with it until the clutch needs replacing. Crap bit of design on Alfas part as far as I'm concerned.
Alexie is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

clutch , pedal , push , whince

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome