Christmas tree of light on GT, Help!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 17-06-10 Thread Starter
Status: -
AO Member
deanogtv's Avatar
Join Date: Aug 2004
Location: United Kingdom
County: Essex
Posts: 116

Member car:


Christmas tree of light on GT, Help!!!

Picked up my 55 plate GT at the weekend, private buy, and it was doing great till yesterday. Just driving along and then bang, VCS system failure warning light flashes up, ten minutes later Motor Control failure warning flashes up and then the ABS and hand brake light come on. A whole Christmas tree of lights!! Speedo is still working but the odometer has stopped, very strange!!!!
Anyway, pop down to the dealer and they link it up to the computer. Diagnosed as a CAN line error!!
Not sure what this is but they reset it and it was fine, until 60 miles down the road, same thing happens again.

Strange this is, is that the car doesn't go into limp mode and there is no change to the car what so ever, it drives perfectly.

I'm taking it back to the stealer next week so hopefully it will get sorted then.

Any advice on this issue would be a massive help

I want to leave this world the same way I entered it, screamy and covered in blood!!!
deanogtv is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

christmas , light , tree

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome