147 engine problem - melted coil / cam belt cover, broken spark plug - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 15-06-10 Thread Starter
Status: -
porkchopexpress's Avatar
Join Date: Jun 2010
Location: United Kingdom
County: Berkshire
Posts: 4
Help 147 engine problem - melted coil / cam belt cover, broken spark plug

Hi guys

I've just bought an 02 plate 2.0L Twin Spark 147 with 85000 miles on the clock. The service history looked good and it had had a cam belt change etc a few months ago.

I took it for its first long drive and after about 100miles into journey the engine suddenly lost power on the motor way and the engine warning light came on. It still ticked over, but sounded like a tractor.

When I pulled over to check under the bonnet there was a lot of melted plastic around one of the engine coils, the spark plugs in the affected coil were broken and part of the plastic cam belt cover had melted.

I'm now looking at getting these replaced (which doesn't look too cheap) and checking for other damage.

Has this happened to anyone else? or does anyone have any ideas on what may have caused this so I can make sure it doesn't happen again.


Last edited by porkchopexpress; 15-06-10 at 22:30.
porkchopexpress is offline  
Sponsored Links
Status: faclifting a 156
AO Silver Member
biffa's Avatar
Join Date: Oct 2006
Location: United Kingdom
County: Lancashire
Posts: 3,199
Images: 9
Soundlike a loose spark plug? only a theory i havent exerienced this myself.
biffa is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , belt , broken , cam , coil , coil or spark , cover , engine , melted , plug , problem , spark

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome