147 - 04 plate - Rust? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 12-06-10 Thread Starter
Status: -
AO Member
Join Date: Jun 2010
Location: United Kingdom
County: Monmouthshire
Posts: 12

Member car:

Alfa 147 TI

147 - 04 plate - Rust?


Recently bought my first ***** an 04 plate, 147 TI, with 41k on the clock.

Had a look undernath and it looks quite rusty especially the exhaust, is it normal for tem to get rusty underneath?

babyben is offline  
Sponsored Links
Status: - Update
Posts: n/a
When you say rusty, is this just the exhaust or the whole floorpan.

Floorpan should be sealed, so it mught just be crud build up.

Exhausts, especially in the UK will rot due to the wet climate
and winter time salt spreading.

Welcome to AO BTW
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,994
Originally Posted by Nev View Post
Floorpan should be sealed,
badly, so they still rust...
David C is offline  
Status: the Alfa is re-born!
AO Member
Join Date: Apr 2010
Location: United Kingdom
County: Tyrone
Posts: 380
I wouldn't worry too much about the exhaust being rusty. I replaced mines 4 weeks ago which also had a dent in it (otherwise I would have left it a while longer), check my post out half-way down this thread:

aopa25 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , plate , rust

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome