GT - Jiggly ride and vibrations - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 10-06-10 Thread Starter
Status: -
AO Member
Brian Lovejoy's Avatar
Join Date: Apr 2003
Location: United Kingdom
County: Derbyshire
Posts: 64
GT - Jiggly ride and vibrations

The ride on my GT seems to be becoming increasingly jiggly/bobbly to the point where it feels like it's got oval or octagonal wheels. Things aren't too bad until about 55mph and over. You can also feel it through steering wheel (all wheels have been done, as has tracking), and feel vibrations through accelerator pedal, and brake pedal when stopping.

Car tracks straight with hands off wheel, but as soon as you put a slight steering input to move left or right car can feel very sensitive, as if it's following a rut - although this isn't consistent. Ride also feels worse over smooth surfaces.

Has anyone experienced anything similar? As I've said the tracking and balancing has all been done, the brake pedal sensation can't be pads, as they've all been replaced. So, I was wondering if any of the following could be the most likely candidate(s):

Front lower or upper wishbones/suspension bushes
Drive shafts
Alloys damaged by pot holes
Rogue tyre

or something else?
Brian Lovejoy is offline  
Sponsored Links
Status: -
AO Member
paullec's Avatar
Join Date: Dec 2008
Location: United Kingdom
County: West Midlands
Posts: 610

Member car:


could be anything. knackered shocks, flat spot on the tyres, buckled rims. Saying that mine horrendous at the mo to
paullec is offline  
Status: -
AO Member
ilovered's Avatar
Join Date: Aug 2003
Location: United Kingdom
County: West Sussex
Posts: 133
Images: 8
From what you describe it sounds like the wheels are buckled. I replaced both my front wheels due to this reason, i tried them on the rear but still noisy, so i replaced them via eBay. Basically alfa wheels on the GT are soft as sh*t and buckle over time. My tyre place noticed it when he was balencing the wheel, looked like a rugby ball Slight exaggeration there but you get my drift. Maybe ask yours to put it on the balancer machine and have a look. beware what you find though, you might not like it !!

oops, finger trouble !
twitter @soppydogcards
ilovered is offline  
Status: Y'all know me.
Join Date: Feb 2010
Location: United Kingdom
County: Gwynedd
Posts: 548

Member car:

GT Cloverleaf

Wheels need balancing by the sound of it.
Resonance is offline  
Status: -
AO Member
Alfaduden's Avatar
Join Date: Feb 2005
Location: Norway
County: Vestfold
Posts: 188
Images: 69
Had to replace mine as well. Bought a set of 8x18 OZ Ultraleggera. Problem solved
But i still feel a tend to som vibrations. Next is change of wheel hubs rear. (at least I Know it is the rear end that the vibrations are comig from.)

BTW. Have you checked drive shafts/joints? May cause vibrations as well you know
Alfaduden is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

jiggly , ride , vibrations

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome