Why did my car let me down??? - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #26 of 29 Old 11-06-10 Thread Starter
Status: loving my 156...
AO Member
Join Date: Jan 2010
Location: United Kingdom
County: Kent
Posts: 29
Evening Guys!

Just to let you know I'm having the rpm/crank sensor replaced on Monday by Day & Whites in Brands Hatch, Kent. Really handy as they're about 15/20 mins from me in Dartford. Got the part in stock..35 and Labour 50.

Can't wait until its fixed because today was the only day since I bought the car in January I haven't used it....

Many thanks for your help & advice....
Chrisw156 is offline  
Sponsored Links
Status: No remission for LUFC !!
AO Silver Member
ronan's Avatar
Join Date: Aug 2009
Location: Belfast
County: Down
Posts: 3,043

Member car:

156 1.8 Turismo

Now that's more like it,Chris.................happy motoring !!
ronan is online now  
Status: -
AO Member
davewood's Avatar
Join Date: Mar 2008
Posts: 13

Member car:

alfa 147 lusso

just done mine 35 for a diagnostic scan and 35 for the part from alfa, fitted it in less than an hour and hopefully thats the end of that cheers guys
davewood is offline  
Status: -
AO Member
AlexB's Avatar
Join Date: Jun 2007
Location: United Kingdom
County: Warwickshire
Posts: 106
Images: 4
Mine failed recently, it would always start from cold and once warm wouldn't cut out but if you turned it off it wouldn't start again for half an hour or so (always before the AA actually managed to turn up)

I took a guess at it being the crank sensor, ordered from Alfa Workshop for 30 + delivery, fitted in 30 mins by a friend. Problem has now gone so must have been the crank sensor. Couldn't see any problem with the wiring or the connector so the sensor itself must have failed.
AlexB is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome