GT- no acceleration, smoke and engine cut out... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 03-06-10 Thread Starter
Status: -
Join Date: Jul 2007
Posts: 3

Member car:


GT- no acceleration, smoke and engine cut out...


For the last month or so i've noticed the acceleration to my 1.9jtdm GT hasnt been what it used to be although it did pick up after around 2,500 rpm.

Last week however I drove it around for a short time with no problems, before going to pull away at a set of traffic lights to find that I had lost all acceleration and thick black smoke was coming from the exhaust. The engine also started struggling to tick over and after 5 minutes of trying, eventually wouldn't tick over at all.

I called the AA and they cleared the EGR (?) valve which seemed to do the trick (although accelerations still wasnt 100%) and said that it should solve the issue.

Today I have just driven round for a short time, to find that exactly the same problem has occurred again. No acceleration, car not ticking over and thick black smoke from the exhaust.

Does anyone have any ideas of the problem? Likely cost of getting it fixed, etc?

Thanks in advance....

benand1981 is offline  
Sponsored Links
Status: Banned for not following the site rules
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
Images: 6
I think you'll have a P0191 code, which will be either the HP pump or wiring.
Smaky is offline  
Status: -
Join Date: Dec 2013
Location: United Kingdom
County: Greater London
Posts: 1
hi, if this helps anyone... my 156 JTD had the same problems, very sluggish lots of black smoke, poor performance and drinking lots of diesel. After few miles the dashboard computer flashed with the message "go to dealer".
I was very near Halfords Autocentre centre in Byfleet at the time, they plugged that diagnostic machine and they changed the ECR valve for about 200 (in Aug/2010). The car drove like a brand new after that and again very economical.
I hope this helps.
kiko is offline  
Status: -
AO Member
Join Date: Sep 2013
Location: United Kingdom
County: -
Posts: 289

Member car:

GT 3.2

EGR? Sounds exactly like the issue I had when I had a GT 1.9

ha ha just noticed this is 3 years old
Alfawoot is offline  
Status: Lowered!!
AO Rosso Alfa Member
Durty dog's Avatar
Join Date: Feb 2009
Location: Northampton
County: Northamptonshire
Posts: 73,506
Images: 18
The EGR can be cleaned but they really need taking apart and cleaned properly, the AA man just done enough to get you home.
Durty dog is offline  
Status: turbo charger assembler
AO Silver Member
Join Date: Nov 2010
Location: United Kingdom
County: West Yorkshire
Posts: 1,928
plus u get one for a saab...its the same and its a touch over 50
hdseven is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

acceleration , cut , engine , smoke

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome