Please help! first overheat then noisy engine and smoke!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 27-05-10 Thread Starter
Status: Looking forward to a drive
AO Member
Join Date: Apr 2008
Location: United Kingdom
County: Cheshire
Posts: 216
Please help! first overheat then noisy engine and smoke!!

1.9 16v JTD GT
07 plate
40,0080 miles
Last service last month at 38K miles

After having the car serviced at an AO recommended independent last month we went up to the lakes (about 150 miles). On the motorway with cruise on at 70mph the car beeps and advises that the water temperature is at maximum, I look down to see the water temp gauge is vertical at 130!

I pulled over at the services and checked the coolant reservoir which showed it just below the MIN line. I topped up with water as that's all i could get, we let the car cool and from that moment to today, the gauge has never gone above 90 and the coolant level has not dropped at all.

Today on my way to work (25 miles) i was sitting in heavy traffic for about 10 minutes when I see a small amount of smoke coming from under the bonnet and a strong smell. The temp gauge is still at 90. I pulled over and opened the bonnet and there were wisps of strong smelling smoke coming from the back off the engine near the bulkhead. I called the AA and they arrived and started the engine and true to form, nothing happened after about 10 minutes of running the engine, raising the revs etc... He took the engine cover off and when he did he said that the belt was very noisy, i could hear it myself - lots of "ticking"from the black plastic belt cover on the left of the engine (sorry, I'm not mechanical at all). He seemed very concerned by this (as was I) but everywhere i look on here it say the interval for changing the belt is 72K, although most people seem to recommend 54K. But then i read the sticky thread on the water pump failures and now I'm not sure at all whether everything is related or just coincidence?
GTMAT is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , noisy , overheat , smoke

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome