interior fan runs constantly - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 23-05-10 Thread Starter
Status: -
Join Date: May 2010
Location: United Kingdom
County: Buckinghamshire
Posts: 2

Member car:


interior fan runs constantly

Hi I wonder if anyone can help with my fan problem with my 156, fan runs constantly even with ignition off also unable to control fan speed
Many thanks
litlor is offline  
Sponsored Links
Status: Alfa tech
AO Member
Join Date: Jun 2007
Location: South Africa
County: Western Cape
Posts: 89

Member car:

156 3.0 V6 24v

Check the fan controller below the cubbyhole, between the fan motor and the transmission tunnel. It has two connectors on it. One small connector and one larger connector. Remove the two retaining screws and withdraw the unit. Closer inspection will show burnt contacts or molten connector, due to poor connection/corrotion.
It may also be possible that the controller may be faulty.
Dev Cloete is offline  
(Post Link) post #3 of 5 Old 24-05-10 Thread Starter
Status: -
Join Date: May 2010
Location: United Kingdom
County: Buckinghamshire
Posts: 2

Member car:


Thank you but have disconnected the fan controller but fan still runs without the ignition on any other ideas
litlor is offline  
Status: -
Join Date: Jan 2011
Location: Ireland
County: Wicklow
Posts: 3

Member car:

'01 Alfa 156

was this ever solved? im currently experiencing this?
mcquaid is offline  
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,620
The fan speed is controlled by the resistor, the resistor is between the negative on the fan and the earth, the fan always gets 12v it is the earth that is switched.

I would imagine the resistor has gone open circuit - normally when they fail they fail closed circuit and it stops the fan running altogether.
Pud237 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

constantly , fan , interior , runs

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome