fiatECUscan CAN Function - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 20-05-10 Thread Starter
Status: faclifting a 156
AO Silver Member
biffa's Avatar
Join Date: Oct 2006
Location: United Kingdom
County: Lancashire
Posts: 3,199
Images: 9
fiatECUscan CAN Function

Hi all, was just reseting airbag light again and noticed whilst using fiatecuscan that it now supports some CAN functions allowing you to reset service counter on the likes of 147's and GT's... Only issue is you have to buy a licence...
biffa is offline  
Sponsored Links
Status: the Alfa is re-born!
AO Member
Join Date: Apr 2010
Location: United Kingdom
County: Tyrone
Posts: 380
I think you need to be using ELM interface for resetting the service counter, think thats the only bit that don't work with OBDII cable??
aopa25 is offline  
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
Originally Posted by aopa25 View Post
I think you need to be using ELM interface for resetting the service counter, think thats the only bit that don't work with OBDII cable??
That's my understanding too. Luckily I have one!
iainfm is offline  
Status: DB9 Top Gear Track
AO Silver Member
pubsinger's Avatar
Join Date: Jan 2007
Location: United Kingdom
County: East Sussex
Posts: 1,629
The ability to reset the service counter was removed in the free Version 2.2, it was available in Version 2.1, I've put it on my bit of webspace, you can download it here.

However, I can't get it to work on my GT 1.9JTDm, the reset process seems to go OK, I get a prompt, warning about reading notes and a choice to abort or continue, after a short pause a 'completed' message pops up yet the 'mls to next service' remains on 0. I do not get any reminders on the dash a service is due.

I asked the question on the FiatECUScan bugs board, Yani seems to think that if it's been reset 9 times it stops nagging and the reset function stops working.

The car is just coming up to its 60K miles services, nowhere near 9 resets, it's possible I suppose that the attempts of my Indie to reset it with his gadget and my attempts with FiatECUScan have disabled it somehow.

All the best


Loose - not close, compact, or tight in structure or arrangement
Lose - to part with or come to be without, as through theft, accident, negligence, etc.
pubsinger is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

fiatecuscan , function

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome