Need some help lads! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 19-05-10 Thread Starter
Status: -
AO Member
Richie 146Boxer's Avatar
Join Date: Dec 2007
Posts: 18

Member car:

'96 146 Boxer

Need some help lads!

Hey i aint been on in a while cause heads been melted with the Selespeed 156 cut long story short i had the engine replaced and the idiot doing it never tightened my clutch and well a bolt came off the pressure plate and thru the box and destroyed it..

I got my hands on a manual one thou and decided to do the changeover all gone well, pedals, stick shifter, box and all gone in perfect but now ive a major issue... How the hell do i bleed the system? I tried the release pin, pull back 4mm and so on like it says online but as it pulls the fluid thru when ya release the air she pulls it back in... Anyone got some serious ideas on how to sort this?? I really miss the car and i aint got the money to be leaving ti to a garage and ive no leaks in masters or slaves bottle changed and everything....

Thanks in advance lads...(this is to refill the system with fluid as it wont gravity fill for me)
Richie 146Boxer is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome