156 airbag light stays on - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 13-05-10 Thread Starter
Status: -
Join Date: May 2010
Location: United Kingdom
County: Cheshire
Posts: 6
156 airbag light stays on

Hi just bought a 03 156 1.9 jtd 16v and guess what? the airbag light stays on.
Has anybody got any easy fixes? im guessing its a common fault.
new2alfas mark is offline  
Sponsored Links
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
Probably a loose wire, or a previously loose wire (or other fault) that's been fixed and not reset (airbag faults don't clear themselves).

You need a KKL lead, a laptop, and either AlfaDiag or FiatECUscan to clear it yourself

One other thought....just check that it's not the warning that the passenger airbag has been disabled. If that applies to 03 models...
iainfm is offline  
Status: -
AO Member
Join Date: Dec 2008
Location: United Kingdom
County: Kent
Posts: 409
With the airbag light on . The airbags are deactivated
supachip is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , airbag , light , stays

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome