Alfa 147 Handling - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 12-05-10 Thread Starter
Status: -
Join Date: May 2010
Location: Ireland
County: Wicklow
Posts: 1

Member car:

Gt 2.0

Alfa 147 Handling


This is my first post and I need help with the handling on a 147...

It seems when I pass 80km and turn into a corner I find myself backing off the steering because the car feels like you could loose it. I've tried to loose it, to a certain extent and cant but its still a very uncomfortable feeling and the faster you go the worse it gets.

I recently had all four wheels aligned by computer which did improve it but didn't cure it completely. Its hard to explain but above 80kms you cant relax... not good on long drives!

Its running on 17inch rims with standard suspension.

I drive a GT and previously owned 2 other 147's with no handling problems.

I'd appreciate anyones input into solving this problem. Thanks.
golly is offline  
Sponsored Links
Status: Missing some horses somewhere :(
AO Member
chillihound's Avatar
Join Date: Oct 2008
Location: United Kingdom
County: Greater London
Posts: 953
What makes you feel uneasy? Are you hearing knocking noises or alike?

With little info it's hard to make a suggestion, fault diagnosis is the biggest part to play in solving a problem.
chillihound is offline  
Status: El finto :(
AO Member
KendalBeefcake's Avatar
Join Date: Mar 2008
Location: United Kingdom
County: Kent
Posts: 886
Images: 4

Member car:

159 SW Ti

Hi, that's strange, My GT on stock suspension was never great, but it never felt as "dangerous" as you describe it If you've had it aligned then it's unlikely that the setup is wrong, only thing I can suggest is that you've got a failed or leaking damper somewhere, you don't actually mention how old the car is as that can be be a factor.. Could be the steering itself..

I would get it checked at a garage of some description! Really, really, doesn't sound safe..
KendalBeefcake is offline  
Status: -
AO Member
Join Date: Feb 2010
Location: United Kingdom
County: Berkshire
Posts: 11

Member car:

Alfa 147

Edit: don't worry
dazmanultra is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , handling

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome