156 2.5 v6 injector light on and throttle problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 12-05-10 Thread Starter
Status: -
AO Member
Join Date: Apr 2008
Location: keswick,lake district
Posts: 18

Member car:

156 2.5 v6

156 2.5 v6 injector light on and throttle problem

hi all,yesterday while driving alfa the injector light came on the dash,this was accompanied by a delay of throttle response of 3 seconds or so after changing each gear..i have tried it today and injector light is on permanently ..car idles fine but at standstill takes 3 seconds or so before it will start to rev and even then it revs up very slowly...when driving car it sets off fine but still has same struggling throttle response after changing gear ...any ideas greatly appreciated...by the way,i had dissconnected maf but to no avail..and it was replaced 2 years ago with a genuine bosch jobbie from alfaman...
trancepants5 is offline  
Sponsored Links
AO Gold Member
davealfa11's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Merseyside
Posts: 9,904
Images: 4

Member car:

156 1.9 mjet 16v

read it first time !!!!!!!!!
davealfa11 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , injector , light , problem , throttle

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome