alfa gt 2.0 jts , model 2005. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 12-05-10 Thread Starter
Status: -
Join Date: May 2010
Location: United Arab Emirates
County: Abu Zaby
Posts: 2
alfa gt 2.0 jts , model 2005.

my car is 45000 KM DRIVEN. brake pads been replaced by the ex-owner couple of months back. they all look good and very good braking but one problem is that the front left hand brake pad strats rubbing the disc and making noise when the car is driven for about 5km. pressing the brake make the noise dissappears but same problem is back again within a minute. any idea what is the problem? does cleaning teh caliper helps? do u think there is a problem in the piston or in the brake hose/pipe?
Maher is offline  
Sponsored Links
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,285
Images: 12
Probably a sticking piston. Fronts just push back, but if they got dirt in, or they have started to rust, this would prevent them from backing off fully.

Alternatively, take the pads out and coat the backs with Copperslip or copper-based grease, then put them back. This stuff works wonders for squeaky brakes.
gazza82 is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

2005 , alfa , jts , model

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome