Loss of power - Cambelt change due - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 03-05-10 Thread Starter
Status: -
AO Member
Join Date: Aug 2008
Location: United Kingdom
County: Blaenau Gwent
Posts: 69
Images: 1

Member car:

156 2.4 JTD

Loss of power - Cambelt change due

My 156 2.0 sele is over due for timing belt change. Was changed about 40K ago,but has had new set of tensioners since then (at about 12K) due to whining noise. Same noise is again occuring and I notice a loss of power. I have ordered new belt set, and need to get a set of camshaft locks but wondered if anyone else has seen similar issues with the tensioners causing loss of power!
mitchok1 is offline  
Sponsored Links
Status: Banned for not following the site rules
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
Images: 6
If it's siezing then yes, but if it's skipped a tooth already the your on borrowed time and SHOULD NOT be driving it, to do the belts you need a little more than cam locks and going solo the first time is not advisable.
Smaky is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

cambelt , change , due , loss , power

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome