bleeding selespeed??? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 30-04-10 Thread Starter
Status: -
Join Date: Apr 2010
Location: Australia
County: Tasmania
Posts: 5
bleeding selespeed???

Hi Just brought a 2005 156 2lit JTS selespeed that was crashed lh front
This broke the selespeed reservoir but the pump and ecu is fine.
I am about to fit a new reservoir and have the correct cs speed flluid to top it up
My question is does it need bleeding or will the return pipe to the reservoir expel all the air??
At present it is stuck in first gear as i have no hydrlaulic pressure.
I have read some posts but some say you need an examiner which is impossible where I live??
others say there is a bleeder on the actuator??

HELP ! I am a newbie to alfa but fell in love when I saw the car and had to take it home !!!
akeepsake is offline  
Sponsored Links
Status: Gold Member
AO Gold Member
rarebear's Avatar
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,021
you should buy Alfadiag (AlfaDiag Alfa Romeo Diagnostic Software) and a cable (preferably mine)
then you can do all the operations to re-instate the selespeed system.
PM me
rarebear is offline  
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
There's a little screw in the actuator next to the hydraulic pipe which is used to initially bleed the system.

After that, what RB says. There's a clutch bleed and a re-calibrate routine to run... After doing the clutch bleed, use the clutch rod length measurement to adjust it to 28.0-28.5mm

How-to here ->
iainfm is offline  
(Post Link) post #4 of 4 Old 01-05-10 Thread Starter
Status: -
Join Date: Apr 2010
Location: Australia
County: Tasmania
Posts: 5
thanks guys am getting Alfadiag and cable will holla for help when it arrives!!
cheers from downunder!
akeepsake is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

bleeding , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome