Sump plug Hell - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Silver Member
armoore's Avatar
Join Date: Jan 2002
Location: United Kingdom
County: Surrey
Posts: 3,690
Now you need to do up the sump plug using a torque wrench. It is only done up to 17 to 21 Nm which is about 15 lbs.ft or ft.lbs if you prefer!

Use a new Dowty washer and you won't have any problems in the future. The problem is that the specified torque does not feel that much (it isn't!) and the temptation is to "tweak" it a bit more. I've lock wired those on my GTV and daughter's 147, not really needed it but it prevents the above temptation.
armoore is offline  
Sponsored Links
Status: On Alfa number 15
AO Platinum Member
symon's Avatar
Join Date: Dec 2005
Location: United Kingdom
County: Oxfordshire
Posts: 33,580
Images: 13
Originally Posted by badgers_nadgers View Post
They had. And it seems they've decided to bring them back again.
Cars built since around 1999 seem to be a lot worse that earlier ones.

I have a feeling the rust protection has been cheapened up.
symon is online now  
Status: Gold Member
AO Gold Member
rarebear's Avatar
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,021
And I thought Alfa had eliminated their rust problems

hehe sounds like Murphy's second law, Murphy was an optimist !
rarebear is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

hell , plug , sump

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome