Clunk when turning the wheel - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 25-04-10 Thread Starter
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
Hmmm Clunk when turning the wheel

My 156 seems to be making a funny clunking noise. I have just finished fitting the new springs, rear suspension components and drivers side lower wishbone. When I turn the wheel back and forth it sort of clunks but it almost sounds like springing metal. All I can think of is that the springs haven't settled. My 155 has always done it and it's been fine for years but this is def new on my 156. The springs aren't quite pushed up to the step in the metal on the shock so are they sliding maybe as I load the wheel each way??? Both 155 and 156 have eibach springs on. Is it a common thing with lowing springs maybe?

BMW E12 M535i, JC racing diff, Gaz coilover, Powerflex.
Alfa 156 GTA, Q2, Super sprint, CF2, EQ, KW coilovers, Eibach rollbars, Powerflex.
Alfa Mito QV , BMC filter.

GitList Member but not as high as Keithy! No Gibbo....I don't need a haircut AO Troublemaker! You have been warned
Joss is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

clunk , turning , wheel

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome