Engine management light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 19-04-10 Thread Starter
Status: -
Join Date: Apr 2010
Location: United Kingdom
County: Devon
Posts: 3
Help Engine management light

Hi Guys,

I don't know if anybody can help but i have my car for about 4 weeks and the engine management light come on for a few hours and then goes off again. Before the light come on the car jolts a couple of times and then the jolting stops and the light comes on. This has been happening for a few weeks, then the other day the car lost power and the light come on and said immobilizer key fauilure and car just cut out. After a few minutes the car started again but the light was still on.
We had the car tested but it did not give us any information.

Please can anybody give me any information as i can ot afford alfa garage prices.

Andrea1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , light , management

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome