New Alfa GT Motor Control Failure - Please, Please help!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 16-04-10 Thread Starter
Status: -
AO Member
Join Date: Feb 2010
Location: United Kingdom
County: Lincolnshire
Posts: 20

Member car:

Mondeo ST220

New Alfa GT Motor Control Failure - Please, Please help!!

H guys as mentioned in the post title - HELP!!

Just bought a 54 red alfa GT coupe - 60,000 miles Fulls ervice history. Picked it up on thursday and had a great run home (50 miles). I bought it for my wife and she is over the moon with it. We probably covered 100 miles yesterday with no probs.

This morning she drove to work and the motor control failure message appeared just after starting the engine.

The car was bought from a dealer with the norm 30 days warranty. The dealer is 40 miles away though.

What should I do? Is there anything I can try? I have tried resetting the ecu to no avail.

I will mention the car came with a dreadful nokia hands free kit mounted on a massive phone holder on the dash. I have removed the phone mount and I snipped the cable and taped the end. This cant be anything to do with the fault can it - surely not.

ANy help will be great guys!!!

A desperate new Alfa owner
deanarse is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jan 2008
Location: Tunbridge Wells
Posts: 279
The motor control system failure is one of those infuriating warnings that could represent a multitude of issues or nothing at all.

When the MCSF first appeared on my '54 GT it was followed intermitantly by immobiliser failure warnings and miscellaneous other warnings that I have forgotten.

If you do a search for "motor control system failure" on the forum, you will find loads of information to determine whether or not yours is serious or not.

The solution in my case was to change the battery, which was the original and 4 years old. This cleared the spurious MCSF messages as the GT computer needs clean voltage to operate correctly.

Alfa Romeo GT Cloverleaf Q2 170bhp
Alfa Romeo 159 Sportwagon TI Q4 210bhp
Intrigued is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alfa , control , failure , motor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome