156 Heater Control - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 06-04-10 Thread Starter
Status: -
Join Date: Apr 2010
Location: United Kingdom
County: Somerset
Posts: 3
156 Heater Control

Hi all,
I'd be geatfull if anyone could give some advice with this one...
I have a 2005 156 jtd with climate control. I have noticed recently, with the warmer weather arriving that once the engine has warmed up my heater blows hot air whether the control is set 16 or 30. The only control over heat i have is to either turn the fan control to off-so that the heater shuts down or to set it to 'low', (at this point the aircon starts which seems to work ok) and turn the ac off. Doing this allows un heated outside air into the car.
alfarob156 is offline  
Sponsored Links
AO Gold Member
davealfa11's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Merseyside
Posts: 9,904
Images: 4

Member car:

156 1.9 mjet 16v

im not sure on this but the heater has 2 sensors in front of heater unit behind grills ,cant see them being faulty but if outside temp on passenger mirror is faulty, im sure this will play silly billies with your heater,im sure someone will correct me on this tho
davealfa11 is offline  
Status: No problems to report its all gravy
AO Member
steviec's Avatar
Join Date: Aug 2009
Location: United Kingdom
County: Cornwall
Posts: 381
Images: 2

Member car:

156 2.4jtd 20v

Have you had a new control panel fitted if so may need reprograming, thats what happened to mine so repaired the old panel and refitted it
steviec is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , climatecontrol , control , fault , heater

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome