Indicator / Hazard Relay Location on a 156 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 06-04-10 Thread Starter
Status: -
AO Member
Join Date: Feb 2010
Location: United Kingdom
County: Hampshire
Posts: 43

Member car:


Indicator / Hazard Relay Location on a 156

Hi all,

On a facelifted interior 156 (1.8 TS), Jan 2003, whereabouts is the relay for the indicator / hazards under the steering column? Can't seem to find it anywhere..

I've read a thread which seems to suggest the steering wheel and airbags needs to be removed to get to it, but I hope not.............could that really be required just to get to the relay?? I have an intermittent problem with the indicators and hazards not working, although the lights flash OK when locking / unlocking.

This thread indicates it plugs into the back of the stalk switches, although it doesn't state what year of 156 this is.

This thread says the relay is cubed shaped, but can't see anything like it in mine, unless I am not looking deep enough. That could be for the older version, as the guys car is a 2.0 TS, which changed to JTS I think at the time of the facelift.

The pictures in this link seem to match what I see - Alfa Romeo forum: Indicator Relay.

Anyone with any experience of this? Thanks.
StevenLunn is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , hazard , indicator , location , relay

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome