Alfa 156 Heater problems AGAIN !??? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 28-03-10 Thread Starter
Status: -
AO Member
garyj123's Avatar
Join Date: Feb 2010
Location: United Kingdom
County: South Yorkshire
Posts: 26
Hmmm Alfa 156 Heater problems AGAIN !???

Hi all. new to this site and new to alfa's so i apologize if i ask the same questions as you may have heard a million times before.
Anyway my problem is, got an alfa 156, and heater didn't work when i got it, the fans work on all the settings, it just never gets warm. I took it to garage and he said it needed a new unit, something what make a flap turn so it knows to blow warm or cold. For temporary he said if i reach up in drivers side behind the unit there is a plastic bit sticking out, turn this and it will either stay warm or cold. I did this till he got the part and like he said it stayed warm all the time.
After putting the part on it worked lovely for about 3 weeks and now i am back in the same position.
I have noticed though even on cold setting and with aircon button pressed it doesn't get cold and on full heat it doesn't get warm, basically its just like the fans are blowing air around, there is no heat control whatsoever.
I checked again under the dash like before for a temporary fix but there is no white plastic thing this time to turn so i cant even do that? Looks like a different unit than before.
Anyone know what i should be looking at to try to sort this out??
i have full fan speed control just no control on hot or cold, just blows the same all the time.

Any help from any of you would be much appreciated

Many thanks

garyj123 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , heater , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome