EGR fix once and for all. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 26-03-10 Thread Starter
Status: -
AO Member
 
paullec's Avatar
 
Join Date: Dec 2008
Location: United Kingdom
County: West Midlands
Posts: 610

Member car:

gt

EGR fix once and for all.

I really need to sought this once and for all on my GT JTD. For the last year i have this really annoying intermediate loss of power below 2k revs. Ive had 2 valves and twice they have been off for cleaning aswell as the throttle body yet it still comes back, which is really starting to get irritating. Im trying to get alfatune for a remap but i cant see the point untill its fixed. Is there a way to actually test these ? its great for like 2 weeks after it been cleaned then it plays up again. i could really do with some pointers

Summary-
2 egr valves in a year
twice cleaned together with throttle bodies
only doing 44mpg on long mway runs at 70mph or worse.
one rac call out due to it sticking open and it wouldnt idle
occasional black smoke on start
major judder when turning off
paullec is offline  
Sponsored Links
Advertisement
 
Status: BEEN AWAY SITE GOT WORSE .....
AO Gold Member
 
davealfa11's Avatar
 
Join Date: Mar 2007
Location: United Kingdom
County: Merseyside
Posts: 9,904
Images: 4

Member car:

156 1.9 mjet 16v

Quote:
Originally Posted by paullec View Post
I really need to sought this once and for all on my GT JTD. For the last year i have this really annoying intermediate loss of power below 2k revs. Ive had 2 valves and twice they have been off for cleaning aswell as the throttle body yet it still comes back, which is really starting to get irritating. Im trying to get alfatune for a remap but i cant see the point untill its fixed. Is there a way to actually test these ? its great for like 2 weeks after it been cleaned then it plays up again. i could really do with some pointers

Summary-
2 egr valves in a year
twice cleaned together with throttle bodies
only doing 44mpg on long mway runs at 70mph or worse.
one rac call out due to it sticking open and it wouldnt idle
occasional black smoke on start
major judder when turning off
speak to gus and he will probably sort your problem out and remap at same time
davealfa11 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
egr , fix

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome