Please help - sick 147 JTD Mjet - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 25-03-10 Thread Starter
Status: -
AO Member
Join Date: Mar 2010
Location: United Kingdom
County: Berkshire
Posts: 11

Member car:

147 JTDm

Help Please help - sick 147 JTD Mjet

Hi everyone - I hope someone can give me some ideas on this.

My 147 currently won't rev over 2000rpm, and the turbo isn't spooling at all. The only warning light I get at all is a glow plug error which the cars had since I bought it nearly 2 years ago. I haven't had the time to look at it this week ( or last week, I had to leave it @ work due to a head injury sustained on my bike :-( ) but it took 3 goes to start today, which is unusual. It also idles a little rough for maybe 3-4 seconds.

Do we think maybe the glow plugs have died after all? If so, is it an easy job and are they readily available? Just to complicate matters, before this happened I chucked some redex in my last full tank....

many many thanks for any help....
MattL is offline  
Sponsored Links
Status: Red
Registered User
Join Date: Jan 2010
Location: United Kingdom
County: Denbighshire
Posts: 173

Member car:


When did you last change the fuel filter? I had this on an old diesel cAr and this was the problem -or is your air filter clogged?
7re43d2 is offline  
Temporary Noble
Status: - Update
Posts: n/a
Based on my recent experience, could be EGRV:


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , jtd , mjet , sick

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome