Alfa 147 2002 heated seats advice - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 25-03-10 Thread Starter
Status: -
AO Member
Join Date: Sep 2008
Location: United Kingdom
County: Bristol
Posts: 97
Lick Alfa 147 2002 heated seats advice

Hi guys, only had my 02' 147 2.0 3dr for a week or two, and only just noticed that the seats have a switch on the side of them for heating... so I pressed it, but it didnt light up, and the same on the passenger side one too.

I'm not overly bothered if the functions broken, as I didnt even realise they were on the car when I bought it.

Although if it was a simple fix or a fuse then I might as well get them sorted... Whats the best way to go about this? thanks guys
tim145j is offline  
Sponsored Links
Status: - Update
Posts: n/a
Check the connectors underneath the seat?
Status: -
AO Silver Member
fredzedex's Avatar
Join Date: Dec 2006
Location: United Kingdom
County: Oxfordshire
Posts: 2,024
Images: 4
had the same with mine,apparently if they've been switched on and the seats been moved(who would do such a thing!!!) it can either blow the fuse or melt the wiring!!!!
fredzedex is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , 2002 , advice , alfa , heated , seats

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome