flickering bulb out - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 22-03-10 Thread Starter
Status: -
AO Member
muggs1958's Avatar
Join Date: Aug 2008
Location: United Kingdom
County: Hampshire
Posts: 149

Member car:

156 2.0 lusso

flickering bulb out

right lads here,s one for you i have a flickering bulb out warning light only when i DONThave the lights on i cant think what it might be any one with some ideas
muggs1958 is offline  
Sponsored Links
AO Gold Member
davealfa11's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Merseyside
Posts: 9,904
Images: 4

Member car:

156 1.9 mjet 16v

brake lights stuck on?
davealfa11 is offline  
Status: - Update
Posts: n/a
You may have a poor connection or more likely a bad earth somewhere in the lighting system. The bulb out warning works on measuring resistance, so a poor earth is usually the culprit. Check all of your bulb connections, make sure the terminals are nice and clean.
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
Remove the rear light clusters (disconnect completely), remove the bulbs, and prise out the bottom connectors a bit, so they make a firmer contact with the bulb.

Worked for mine.
iainfm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

bulb , flickering

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome