Do I need a new battery? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 07-03-10 Thread Starter
Status: Let the V6 howl!
Club Member
Membro Medio
A_Venables's Avatar
Club Member Number: 866
Join Date: Sep 2008
Location: United Kingdom
County: West Midlands
Posts: 364
Do I need a new battery?

Ive had a few strange things happen recently with the misses 147, came to it one frosty morning last week and the windows were open a touch (were up when locked up at previous night) so unlocked the car and it locked it self straightaway (im using the key as remotes dont work). I had to unlock and pull the door handle straightaway to get in. I started the car (was fine) but the interior unlock button was lit and the other doors still locked, tryed the unlock switch, it just locked straight after unlocking. Turned the engine off and locked the drivers door with key, then unlocked again, after this all was fine.
This Saturday unlocked the car, opened the boot by the button on the dash, boot opened but radio also came on!
Ive had no warning lights or messages, just those two things. Should I be worried?
A_Venables is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome