156 doubts... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 05-03-10 Thread Starter
Status: -
Join Date: Mar 2010
Location: Costa Rica
County: San Jose
Posts: 1

Member car:

156 2.0 16V 2003

Hmmm 156 doubts...

Hi Im new here,

My dad is going to buy a 2003 156 Selespeed. We both are in love with these car but also a little worried about the problems it might give us...

The warning light was on and the car used to turn to neutral, the actual owner took the car to get fix and its not longer giving this problem. But we still want to know what could be the cause of this. What things could cause this problem? Low oil? Could it be something serious?

Are there any special cares or things we need be checking regurarly with this car? Apart from the regular things you check on any car of course...

Last, are there any know issues or issues that have been resolved with this 156 model?

Thank You!

PS: Sorry for my english...Im from Costa Rica
gsj889 is offline  
Sponsored Links
AO Gold Member
davealfa11's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Merseyside
Posts: 9,904
Images: 4

Member car:

156 1.9 mjet 16v

any problems with selespeeds from what ive read on this forum usually translates to no one knows how to maintain them,simple things like pushrod adjusstment,some garages havent a clue ,
heres a buyers guide for you to browse
Alfa Romeo 156 Buyer's Guide
davealfa11 is offline  
Status: pothole avoidance score - 9 out of 10
AO Silver Member
Laptop_Matt's Avatar
Join Date: Dec 2006
Location: United Kingdom
County: Derbyshire
Posts: 3,036
Images: 33
Most issues are simple issues.

Do you know exactly what was fixed with the car when the owner took it to get fixed?

I've had mine 4 years, had some pretty simple problems - pump relay sooting up (7 to replace)

And got a major problem at the moment as my actuator went (it had done nearly 100k miles which is longer than i expected).

My advise is to read up on exactly how the system works and how to perform maintenance checks. Recalibrating the system is required from time to time too aswell as clutch push-rod adjustment (as davealfa11 mentioned)

Only take it to a specialist!

I wouldnt swap mine for the world, its a facinating system

2002 156 Selespeed Sportwagon|Koni FSD Dampers|Eibach Pro Springs|Fully Powerflexed Front & Rear|Eibach Sports Stabiliser ARB's|Lightweight Flywheel|Lighweight Crank Pulley|Colombo & Bariani Cams|Ported by Peak Alfa|Custom Remap by Gus|Wiechers Aluminium Strut Brace|GTA Uprights & Brembo 330mm Conversion|276mm GTA Rear's|GTA Steering Rack |Custom K&N Intake Pipe & Induction|Brand new Gearbox/Actuator|Quaife LSD|CF2 Decat Manifolds|Supersprint Centre Section|CSC Duplex Exhaust|GTA Interior
Laptop_Matt is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 156advice , doubts , problems , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome