Odometer problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 04-03-10 Thread Starter
Status: -
Join Date: Mar 2010
Location: United Kingdom
County: Durham
Posts: 1

Member car:


Odometer problems

Hi all
I am looking to buy a 147 1.9jtd lusso on an 53 plate. I test drove it today and while it seemed fine to drive and when ticking over the odometer was flashing constantly the whole time. Does anyone know the exact possible causes of this problem?
I know there has been a few bits and pieces of what I have seen on here regarding the CAN BUS etc !
When I test drove it the number plate light came up as needing this replacing - could this cause such a thing?
Any ideas would be much appreciated!
I used to have a 156 2.4jtd when I lived in Austria and loved it and desperatly want to have an Alfa again but have a limited budget.
Thanks in advance
sclayton76 is offline  
Sponsored Links
Status: Enjoying a nice mug of tea
AO Silver Member
Join Date: Oct 2008
Location: United Kingdom
County: Bedfordshire
Posts: 1,752
I remember reading in an earlier thread that if you start a 147 before it has finished it's start up checks it tends to get upset.

The number plate bulb out is just that - a bulb has blown.
CJO is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

odometer , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome