Another problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 24-02-10 Thread Starter
Status: -
AO Member
paullec's Avatar
Join Date: Dec 2008
Location: United Kingdom
County: West Midlands
Posts: 610

Member car:


Another problem

Im getting abit annoyed now with my GT JTD . So far in the last 3 months ive had or had to replace

in order.

power problem
Replace EGR
injector bust the seals
glow plugs
still take ages to start
car not started which was another egr failure ( which resulted in a RAC call out )

Now i have another power loss problem sometime it take a while to turn over, it stinks of carbon and the whole engine judders when i turn it off. Any clues to why it would judder on turn off, im talking big wobble jolt lol
paullec is offline  
Sponsored Links
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
Sounds like a minor case of it running-on on one cylinder. Possibly an oil leak?
iainfm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome